Massive Assault Official Forum
   
It is currently Fri Nov 16, 2018 11:21 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 16 posts ] 
Author Message
 Post subject: Man2 does not work after installing new patch
PostPosted: Wed Feb 18, 2009 12:54 am 
Offline
Tough Nut

Joined: Fri Jul 27, 2007 10:48 pm
Posts: 26
Karma: 0

Location: Cincinnati, Ohio, USA
Hi!
I installed the patch man2.0.255 for Altalim, which deleted my man2.exe file. So, I downloaded the full version of man2 2.0.249full.exe. Now, the new version runs OK (I even have altalim) but does not connect to the Internet!

-- careless

_________________
Ignore the Fools


Top
 Profile  
 
 Post subject:
PostPosted: Wed Feb 18, 2009 2:43 am 
Offline
Developer
User avatar

Joined: Tue Jul 01, 2008 10:31 am
Posts: 791
Karma: 18
Re-download patch.
http://massiveassaultnetwork.com/downlo ... tch_en.exe


Top
 Profile  
 
 Post subject: Problems after installing patch
PostPosted: Wed Feb 18, 2009 10:15 pm 
Offline
Tough Nut

Joined: Fri Jul 27, 2007 10:48 pm
Posts: 26
Karma: 0

Location: Cincinnati, Ohio, USA
OK, I re-downloaded and ran the patch. Now, all my "Sent and Received" games show up as "Time is Up". I still connect to the game server!

_________________
Ignore the Fools


Top
 Profile  
 
 Post subject:
PostPosted: Wed Feb 18, 2009 10:16 pm 
Offline
Tough Nut

Joined: Fri Jul 27, 2007 10:48 pm
Posts: 26
Karma: 0

Location: Cincinnati, Ohio, USA
Sory, should have said I still cannot connect to the game server

_________________
Ignore the Fools


Top
 Profile  
 
 Post subject:
PostPosted: Thu Feb 19, 2009 3:51 am 
Offline
Developer
User avatar

Joined: Tue Jul 01, 2008 10:31 am
Posts: 791
Karma: 18
Try to change your battlenet port from 6006 to 6548:

open file SAVE/your_profile/net/settings.ini, find a lines
battlenet_port = 6006
and change it to
battlenet_port = 6548

careless wrote:
Sory, should have said I still cannot connect to the game server


Top
 Profile  
 
 Post subject:
PostPosted: Thu Feb 19, 2009 8:33 pm 
Offline
Tough Nut

Joined: Fri Jul 27, 2007 10:48 pm
Posts: 26
Karma: 0

Location: Cincinnati, Ohio, USA
I changed the port, still no luck. As soon as I click on my Profile name, I see a lot of games listed with all the games that are still in my "Sent and Finished" folder also showing up in my "Games" folder, but with 'Time is up',. But, as soon as I log on a window pops up saying that I was unable to connect to the server.

Here's the weird thing -- I had saved a copy of the man2.exe file that came with the full game download (V249), as oldman2.exe. If I fire that up I still have connectivity problems, but the list of games is correct.

I am willing to totally uninstall and delete the folder and start over, if that will help in any way. Also, I don't remember what I did to become a registered player. Is there a file that contains my decoder ring?

Thanks, Jedi_Knight!

_________________
Ignore the Fools


Top
 Profile  
 
 Post subject:
PostPosted: Thu Feb 19, 2009 11:04 pm 
Offline
Developer
User avatar

Joined: Tue Jul 01, 2008 10:31 am
Posts: 791
Karma: 18
Try to copy your SAVE folder and settings.ini file from
c:\program files\Massive Assault Network 2\
to new location
c:\documents and settings\YOUR_PROFILE\massive assault network 2 (this folder is created by a patch).


Top
 Profile  
 
 Post subject:
PostPosted: Fri Feb 20, 2009 7:49 pm 
Offline
Tough Nut

Joined: Fri Jul 27, 2007 10:48 pm
Posts: 26
Karma: 0

Location: Cincinnati, Ohio, USA
Copied /save and settings.ini as instructed. Now, the list of games is correct. But, I still get a failure connecting to game server. :-(

_________________
Ignore the Fools


Top
 Profile  
 
 Post subject:
PostPosted: Sat Feb 21, 2009 3:05 am 
Offline
Developer
User avatar

Joined: Tue Jul 01, 2008 10:31 am
Posts: 791
Karma: 18
careless wrote:
Copied /save and settings.ini as instructed. Now, the list of games is correct. But, I still get a failure connecting to game server. :-(

That's bad, because connection problems is based upon firewall settings, router settings, your provider settings and it's hard to locate problem.
for example, i have two computers connected through Di-624 router to LAN network, and VPN-tunnel to internet. Computer that have Kaspersky Security Service couldn't connect to server i don't kno why, but after i used some magic on it, connection works :)
Check your firewall settings, antivirus filter, ADSL modem (if you have it)...


Top
 Profile  
 
 Post subject:
PostPosted: Sat Feb 21, 2009 9:25 am 
Offline
Tough Nut

Joined: Fri Jul 27, 2007 10:48 pm
Posts: 26
Karma: 0

Location: Cincinnati, Ohio, USA
OK, thanks, I will look into it. Just FYI, I turned off anti-virus and firewall, still have a problem. So, I "turned back the clock" by a week using System Restore -- which took me back to V249 before the patch. Now, as soon as I click on my Profile name, I get a Windows crash :-( My internet connection is fine, which is why I can send these messages to you. I will keep trying other things, will let you know if I figure it out.

_________________
Ignore the Fools


Top
 Profile  
 
 Post subject:
PostPosted: Sun Feb 22, 2009 12:47 pm 
Offline
Tough Nut

Joined: Fri Jul 27, 2007 10:48 pm
Posts: 26
Karma: 0

Location: Cincinnati, Ohio, USA
Sorry, turns out that I had Zone Alarm active, but cleverly hidden. Did not show up in my applications or services. But, when I started uninstalling several unused programs, including Zone Alarm, I found that it was actually running! Bad Zone Alarm!

Thanks for all your help.

_________________
Ignore the Fools


Top
 Profile  
 
 Post subject:
PostPosted: Sat Feb 28, 2009 8:01 pm 
Offline
Tough Nut

Joined: Sat Feb 28, 2009 7:39 pm
Posts: 23
Karma: 0
Jedi_Knight wrote:
Try to copy your SAVE folder and settings.ini file from
c:\program files\Massive Assault Network 2\
to new location
c:\documents and settings\YOUR_PROFILE\massive assault network 2 (this folder is created by a patch).


Since patching to 255 (and i think my experience here is unique in this kind of problems) i can seemingly only run the game through the patch itself.

What I am saying is that the exe or lnk do not work, however REpatching the game asks me to launch and if i say yes the game works. I suppose there's a workaround for this, however the folder you just mentioned does not exist here. It is here instead:

C:\Users\GShock\AppData\Local\VirtualStore\Program Files\Massive Assault Network 2

I followed your instructions, however the SAVE folder in the game installation folder (program files) is empty, so i copied just the folder. I also copied the settings.ini but still... no go.
What am i supposed to do to fix this? lol i can't repatch the game everytime i wanna play, can I?


Top
 Profile  
 
 Post subject:
PostPosted: Sat Feb 28, 2009 9:45 pm 
Offline
Tough Nut

Joined: Sat Feb 28, 2009 7:39 pm
Posts: 23
Karma: 0
So after a little messing around, i found out that basically it's not a compatibility mode that is missing but Vista requires this game to be run only as admin.

Anyone having same problem (.255 ctd as soon as program is started) can just edit properties of the .lnk file:
Set privilege level to admin (compatibility tab)....on the other hand, the prog doesn't require any compatibility mode at all.

Considering vista messes up basically with everything residing in the program files folder, also copy the SAVE folder and the settings.ini into the

C:\Users\[your admin user account]\AppData\Local\VirtualStore\Program Files\Massive Assault Network 2 ...

and that should work as a charm.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Mar 01, 2009 6:08 am 
Offline
Developer
User avatar

Joined: Tue Jul 01, 2008 10:31 am
Posts: 791
Karma: 18
"Documents and Settings" in XP = "Users" in Vista.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Mar 02, 2009 10:12 am 
Offline
Tough Nut

Joined: Sat Feb 28, 2009 7:39 pm
Posts: 23
Karma: 0
Another good thing to post about the after patch process...

the profile is lost...instead of re registering like i did and...panicking when the re reg fails, just restore the profile.

Everything works perfect...phewww sorry for bugging the support team. :)


Top
 Profile  
 
 Post subject:
PostPosted: Tue Mar 03, 2009 1:50 am 
Offline
Developer
User avatar

Joined: Tue Jul 01, 2008 10:31 am
Posts: 791
Karma: 18
2.0.255 stores all data in
c:\Users\YOURPROFILE\Massive Assault Network 2\

2.0.249 stores all data in program folder.
that's why 2.0.255 works without administrative permissions on Vista.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 16 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Karma functions powered by Karma MOD © 2007, 2009 m157y